mamona-installer-0.2.5: adding ebuild
Ricardo Salveti [Sun, 1 Feb 2009 07:18:11 +0000 (04:18 -0300)]
Signed-off-by: Ricardo Salveti <ricardo.salveti@openbossa.org>

dev-embedded/mamona-installer/Manifest [new file with mode: 0644]
dev-embedded/mamona-installer/mamona-installer-0.2.5.ebuild [new file with mode: 0644]

diff --git a/dev-embedded/mamona-installer/Manifest b/dev-embedded/mamona-installer/Manifest
new file mode 100644 (file)
index 0000000..d47ad37
--- /dev/null
@@ -0,0 +1,2 @@
+DIST mamona-installer_0.2.5.tar.gz 3352852 RMD160 a9cf3c9c0530b47b29b2208c6f91c432d61a37d7 SHA1 2ec68246ae84855c71d87b00eba3b6d70e743fc2 SHA256 8e683c3b9686d8aedae2b85530f679b8f53621b9d23b3ea664784936e3a9e152
+EBUILD mamona-installer-0.2.5.ebuild 1677 RMD160 a329658fdfe3bc8081a2cc02835a53cf339395f6 SHA1 56ddcb0a8cc900db1065b64ff03ead8f882d1607 SHA256 6524b0335df8f72f2a5f66d06efc51b9631711fa5a7281191758180d19a4aba0
diff --git a/dev-embedded/mamona-installer/mamona-installer-0.2.5.ebuild b/dev-embedded/mamona-installer/mamona-installer-0.2.5.ebuild
new file mode 100644 (file)
index 0000000..e734da5
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 2009 Ricardo Salveti de Araujo
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Scripts and programs needed to fully use Mamona Embedded distribution."
+HOMEPAGE="http://dev.openbossa.org/trac/mamona/wiki"
+SRC_URI="http://dev.openbossa.org/mamona/0.2/installer/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/libc
+       sys-libs/zlib
+       app-text/texi2html
+       sys-apps/util-linux
+       sys-apps/coreutils
+       sys-apps/which
+       mail-filter/procmail
+       dev-util/cdebootstrap
+       sys-devel/bison
+       dev-util/ccache
+       net-misc/curl
+       dev-util/cvs
+       app-text/xmlto
+       app-text/docbook-sgml-utils
+       sys-apps/fakeroot
+       dev-util/git
+       sys-apps/help2man
+       dev-util/intltool
+       >=dev-lang/python-2.4
+       dev-python/pexpect
+       dev-python/pysqlite
+       dev-util/subversion
+       sys-apps/texinfo
+       app-arch/unzip
+       net-misc/wget
+       app-text/openjade
+       app-admin/reprepro
+       sys-apps/groff
+       sys-devel/patch
+       dev-util/quilt
+       sys-fs/mtd-utils
+       app-admin/sudo"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+       if [ "$(gcc-major-version)" == "4" ]; then
+               eerror "mamona-qemu-arm requires gcc-3 in order to build and work correctly"
+               eerror "please compile it switching to gcc-3."
+               eerror "We are aware that mamona-qemu-arm can guess a gcc-3 but this feature"
+               eerror "could be harmful."
+               die "gcc 4 cannot build mamona-qemu-arm"
+       fi
+}
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       if [[ ! -e configure ]] ; then
+               ./autogen.sh || die "autogen failed"
+       fi
+}
+
+src_install() {
+       emake install DESTDIR="${D}" || die "emake install failed"
+
+       dodoc AUTHORS COPYING INSTALL NEWS README ChangeLog
+}